import re
regex = re.compile(r"(?<=^(?:[^/]+\/){2})[^/]+")
test_str = "this/is/some/url"
subst = "a"
result = regex.sub(subst, test_str)
if result:
print(result)