import Foundation
let pattern = #"(?<=^(?:[^/]+\/){2})[^/]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"this/is/some/url"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"a"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)