$re = '/(?<=^(?:[^/]+\/){2})[^/]+/';
$str = 'this/is/some/url';
$subst = "a";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;