use strict;
my $str = 'this/is/some/url';
my $regex = qr/(?<=^(?:[^/]+\/){2})[^/]+/p;
my $subst = 'a';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";