# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\\/*((?:[^\/]+\\/){2})[^\/]+/$1a/gm;t' <<< "this/is/some/url
/this/is/some/url"