$re = '/^\/*((?:[^/]+\/){2})[^/]+/m';
$str = 'this/is/some/url
/this/is/some/url';
$subst = "$1a";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;