import re
regex = re.compile(r"^\/*((?:[^/]+\/){2})[^/]+", flags=re.MULTILINE)
test_str = ("this/is/some/url\n"
"/this/is/some/url")
subst = "$1a"
result = regex.sub(subst, test_str)
if result:
print(result)