// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/*((?:[^/]+\/){2})[^/]+").unwrap();
let string = "this/is/some/url
/this/is/some/url";
let substitution = "$1a";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}