#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\/*((?:[^/]+\/){2})[^/]+"
Local $sString = "this/is/some/url" & @CRLF & _
"/this/is/some/url"
Local $sSubst = "$1a"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)