# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(".*?")|((?<group>\b([A-z*]+))-)/${group} $1/gm;t' <<< "Jean-Pierre bought \"blue-green-red\" product-2345 and other blue-red stuff. \"a-a\""