package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(".*?")|((?<group>\b([A-z*]+))-)`)
var str = `Jean-Pierre bought "blue-green-red" product-2345 and other blue-red stuff. "a-a"`
var substitution = "${group} $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}