use strict;
my $str = 'Jean-Pierre bought "blue-green-red" product-2345 and other blue-red stuff. "a-a"';
my $regex = qr/(".*?")|((?<group>\b([A-z*]+))-)/mp;
my $subst = '${group} $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";