// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(".*?")|((?<group>\b([A-z*]+))-)"#).unwrap();
let string = "Jean-Pierre bought \"blue-green-red\" product-2345 and other blue-red stuff. \"a-a\"";
let substitution = "${group} $1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}