re = /(".*?")|((?<group>\b([A-z*]+))-)/m
str = 'Jean-Pierre bought "blue-green-red" product-2345 and other blue-red stuff. "a-a"'
subst = '${group} $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result