import Foundation
let pattern = #"(".*?")|((?<group>\b([A-z*]+))-)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Jean-Pierre bought "blue-green-red" product-2345 and other blue-red stuff. "a-a""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${group} $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)