#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^W(\d(\d(\d[A-Z]?)?)?)?$"
Local $sString = "W" & @CRLF & _
"W1" & @CRLF & _
"W12" & @CRLF & _
"W123" & @CRLF & _
"W123A" & @CRLF & _
"" & @CRLF & _
"-- casos inválidos (tem que ter exatamente 3 dígitos antes do X, a regex não pega esses casos)" & @CRLF & _
"W1X" & @CRLF & _
"W12X"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")