package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^W(\d(\d(\d[A-Z]?)?)?)?$`)
var str = `W
W1
W12
W123
W123A
-- casos inválidos (tem que ter exatamente 3 dígitos antes do X, a regex não pega esses casos)
W1X
W12X`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}