import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^W(\\d(\\d(\\d[A-Z]?)?)?)?$";
final String string = "W\n"
+ "W1\n"
+ "W12\n"
+ "W123\n"
+ "W123A\n\n"
+ "-- casos inválidos (tem que ter exatamente 3 dígitos antes do X, a regex não pega esses casos)\n"
+ "W1X\n"
+ "W12X";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}