using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^W(\d(\d(\d[A-Z]?)?)?)?$";
string input = @"W
W1
W12
W123
W123A
-- casos inválidos (tem que ter exatamente 3 dígitos antes do X, a regex não pega esses casos)
W1X
W12X";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}