use strict;
my $str = 'W
W1
W12
W123
W123A
-- casos inválidos (tem que ter exatamente 3 dígitos antes do X, a regex não pega esses casos)
W1X
W12X';
my $regex = qr/^W(\d(\d(\d[A-Z]?)?)?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}