import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^;]+);([^;]+);((?:\\d{4}|\\?{4})-(?:\\d\\d|\\?{2})-(?:\\d\\d|\\?{2}))$";
final String string = "bla;blubb;1234-45-34\n"
+ "sfsdf;sdfsf;2432-09-??\n"
+ "sffd;sdfsd;3423-??-??\n"
+ "df sdf; sdd sd sssssfdsw;????-??-??";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}