import re
regex = re.compile(r"^([^;]+);([^;]+);((?:\d{4}|\?{4})-(?:\d\d|\?{2})-(?:\d\d|\?{2}))$", flags=re.MULTILINE)
test_str = ("bla;blubb;1234-45-34\n"
"sfsdf;sdfsf;2432-09-??\n"
"sffd;sdfsd;3423-??-??\n"
"df sdf; sdd sd sssssfdsw;????-??-??")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")