// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^;]+);([^;]+);((?:\d{4}|\?{4})-(?:\d\d|\?{2})-(?:\d\d|\?{2}))$").unwrap();
let string = "bla;blubb;1234-45-34
sfsdf;sdfsf;2432-09-??
sffd;sdfsd;3423-??-??
df sdf; sdd sd sssssfdsw;????-??-??";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}