use strict;
my $str = 'bla;blubb;1234-45-34
sfsdf;sdfsf;2432-09-??
sffd;sdfsd;3423-??-??
df sdf; sdd sd sssssfdsw;????-??-??';
my $regex = qr/^([^;]+);([^;]+);((?:\d{4}|\?{4})-(?:\d\d|\?{2})-(?:\d\d|\?{2}))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}