#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\n]*слово[^\n]*(?:\n[^\n]*){2}$"
Local $sString = "сперва было слово" & @CRLF & _
"и потом то " & @CRLF & _
"что нужно было сматчить" & @CRLF & _
"а это матчить не нужно" & @CRLF & _
"но вот снова слово" & @CRLF & _
"и эти строки" & @CRLF & _
"опять нужно матчить" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")