import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\n]*слово[^\\n]*(?:\\n[^\\n]*){2}$";
final String string = "сперва было слово\n"
+ "и потом то \n"
+ "что нужно было сматчить\n"
+ "а это матчить не нужно\n"
+ "но вот снова слово\n"
+ "и эти строки\n"
+ "опять нужно матчить\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}