// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\n]*слово[^\n]*(?:\n[^\n]*){2}$").unwrap();
let string = "сперва было слово
и потом то
что нужно было сматчить
а это матчить не нужно
но вот снова слово
и эти строки
опять нужно матчить
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}