$re = '/^[^\n]*слово[^\n]*(?:\n[^\n]*){2}$/m';
$str = 'сперва было слово
и потом то
что нужно было сматчить
а это матчить не нужно
но вот снова слово
и эти строки
опять нужно матчить
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);