package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\n]*слово[^\n]*(?:\n[^\n]*){2}$`)
var str = `сперва было слово
и потом то
что нужно было сматчить
а это матчить не нужно
но вот снова слово
и эти строки
опять нужно матчить
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}