const regex = /^[^\n]*слово[^\n]*(?:\n[^\n]*){2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\n]*слово[^\\n]*(?:\\n[^\\n]*){2}$', 'gm')
const str = `сперва было слово
и потом то
что нужно было сматчить
а это матчить не нужно
но вот снова слово
и эти строки
опять нужно матчить
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}