re = /^[^\n]*слово[^\n]*(?:\n[^\n]*){2}$/m
str = 'сперва было слово
и потом то
что нужно было сматчить
а это матчить не нужно
но вот снова слово
и эти строки
опять нужно матчить
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end