#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:\G(?!^)\h+|\bexcept\h+)\K\w+"
Local $sString = " wholesale trade except motor vehicles motorcycles" & @CRLF & _
" retail trade except motor vehicles motorcycles"
Local $sSubst = "MATCH"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)