$re = '/(?:\G(?!^)\h+|\bexcept\h+)\K\w+/';
$str = ' wholesale trade except motor vehicles motorcycles
retail trade except motor vehicles motorcycles';
$subst = "MATCH";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;