const regex = /(?:\G(?!^)\h+|\bexcept\h+)\K\w+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)\\h+|\\bexcept\\h+)\\K\\w+', 'g')
const str = ` wholesale trade except motor vehicles motorcycles
retail trade except motor vehicles motorcycles`;
const subst = `MATCH`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);