using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)\h+|\bexcept\h+)\K\w+";
string substitution = @"MATCH";
string input = @" wholesale trade except motor vehicles motorcycles
retail trade except motor vehicles motorcycles";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}