import re
regex = re.compile(r"(?:\G(?!^)\h+|\bexcept\h+)\K\w+")
test_str = (" wholesale trade except motor vehicles motorcycles\n"
" retail trade except motor vehicles motorcycles")
subst = "MATCH"
result = regex.sub(subst, test_str)
if result:
print(result)