import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!^)\\h+|\\bexcept\\h+)\\K\\w+";
final String string = " wholesale trade except motor vehicles motorcycles\n"
+ " retail trade except motor vehicles motorcycles";
final String subst = "MATCH";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}