# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[{}[\]]+|"\d+"://g;t' <<< "{\"5\":[19,18,20],\"6\":[28]}"