use strict;
my $str = '{"5":[19,18,20],"6":[28]}';
my $regex = qr/[{}[\]]+|"\d+":/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";