using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[{}[\]]+|""\d+"":";
string substitution = @"";
string input = @"{""5"":[19,18,20],""6"":[28]}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}