$re = '/[{}[\]]+|"\d+":/';
$str = '{"5":[19,18,20],"6":[28]}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;