#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[{}[\]]+|"\d+":"
Local $sString = "{"5":[19,18,20],"6":[28]}"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)