# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:.*?\b(.+?)\1(?=\b|\p{Lu}))*\s*(.*)/\3/gm;t' <<< "Lil' SlimLil' Slim feat. PxMxWxPxMxWx Where Your Ward At!!
I Like It (Mannie Fresh Style)I Like It (Mannie Fresh Style)Ms. Tee
Bella VistaBella Vista Mister Wong
Tom WareTom WareChina Town
Race 'N RhythmRace 'N Rhythm Teenage Girls
Ronald MarquisseRonald MarquisseElectro Link 7
PleasurePleasure Thoughts Of Old Flames
OM, OM, Dom Um RomaoDom Um Romao Chipero"