import Foundation
let pattern = #"^(?:.*?\b(.+?)\1(?=\b|\p{Lu}))*\s*(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Lil' SlimLil' Slim feat. PxMxWxPxMxWx Where Your Ward At!!
I Like It (Mannie Fresh Style)I Like It (Mannie Fresh Style)Ms. Tee
Bella VistaBella Vista Mister Wong
Tom WareTom WareChina Town
Race 'N RhythmRace 'N Rhythm Teenage Girls
Ronald MarquisseRonald MarquisseElectro Link 7
PleasurePleasure Thoughts Of Old Flames
OM, OM, Dom Um RomaoDom Um Romao Chipero
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)