$re = '/^(?:.*?\b(.+?)\1(?=\b|\p{Lu}))*\s*(.*)/m';
$str = 'Lil\' SlimLil\' Slim feat. PxMxWxPxMxWx Where Your Ward At!!
I Like It (Mannie Fresh Style)I Like It (Mannie Fresh Style)Ms. Tee
Bella VistaBella Vista Mister Wong
Tom WareTom WareChina Town
Race \'N RhythmRace \'N Rhythm Teenage Girls
Ronald MarquisseRonald MarquisseElectro Link 7
PleasurePleasure Thoughts Of Old Flames
OM, OM, Dom Um RomaoDom Um Romao Chipero';
$subst = "\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;