# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:.*?\b(.+?)\1(?=\b|\p{Lu}))*\s*(.*)"
test_str = ("Lil' SlimLil' Slim feat. PxMxWxPxMxWx Where Your Ward At!!\n"
"I Like It (Mannie Fresh Style)I Like It (Mannie Fresh Style)Ms. Tee\n"
"Bella VistaBella Vista Mister Wong\n"
"Tom WareTom WareChina Town\n"
"Race 'N RhythmRace 'N Rhythm Teenage Girls\n"
"Ronald MarquisseRonald MarquisseElectro Link 7\n"
"PleasurePleasure Thoughts Of Old Flames\n"
"OM, OM, Dom Um RomaoDom Um Romao Chipero")
subst = "\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.