using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:.*?\b(.+?)\1(?=\b|\p{Lu}))*\s*(.*)";
string substitution = @"\3";
string input = @"Lil' SlimLil' Slim feat. PxMxWxPxMxWx Where Your Ward At!!
I Like It (Mannie Fresh Style)I Like It (Mannie Fresh Style)Ms. Tee
Bella VistaBella Vista Mister Wong
Tom WareTom WareChina Town
Race 'N RhythmRace 'N Rhythm Teenage Girls
Ronald MarquisseRonald MarquisseElectro Link 7
PleasurePleasure Thoughts Of Old Flames
OM, OM, Dom Um RomaoDom Um Romao Chipero";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}