import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*?\\b(.+?)\\1(?=\\b|\\p{Lu}))*\\s*(.*)";
final String string = "Lil' SlimLil' Slim feat. PxMxWxPxMxWx Where Your Ward At!!\n"
+ "I Like It (Mannie Fresh Style)I Like It (Mannie Fresh Style)Ms. Tee\n"
+ "Bella VistaBella Vista Mister Wong\n"
+ "Tom WareTom WareChina Town\n"
+ "Race 'N RhythmRace 'N Rhythm Teenage Girls\n"
+ "Ronald MarquisseRonald MarquisseElectro Link 7\n"
+ "PleasurePleasure Thoughts Of Old Flames\n"
+ "OM, OM, Dom Um RomaoDom Um Romao Chipero";
final String subst = "\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}