#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\w\.]+):([\w\-]+):(\w+).*:([\w\.]+):"
Local $sString = "org.eclipse.aether:aether-impl:jar:0.9.0.M2:compile" & @CRLF & _
"com.google.code.findbugs:annotations:jar:3.0.0:compile" & @CRLF & _
"org.sonatype.sisu:sisu-guice:jar:no_aop:3.1.0:compile"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")