using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w\.]+):([\w\-]+):(\w+).*:([\w\.]+):";
string input = @"org.eclipse.aether:aether-impl:jar:0.9.0.M2:compile
com.google.code.findbugs:annotations:jar:3.0.0:compile
org.sonatype.sisu:sisu-guice:jar:no_aop:3.1.0:compile";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}